Author Topic: Arrow not straight/overlapping/gaps  (Read 4422 times)

Offline Norshah

  • Jr. Member
  • **
  • Posts: 5
Arrow not straight/overlapping/gaps
« on: August 06, 2014, 08:53 PM »
Hi, my arrows have gap between them + they are not straight + they are overlapping when I tried to close the gap by moving the process box or the yellow points. See attachment for the screenshot.

Any clue how to fix this? The stack arrows in the PDF user manual looks straight and perfect.

Thanks



Offline pbeilschmidt

  • Administrator
  • Hero Member
  • *****
  • Posts: 597
  • e!Sankey - show the flow.
    • e!Sankey - show the flow.
Re: Arrow not straight/overlapping/gaps
« Reply #1 on: August 07, 2014, 08:45 AM »
Hello Norshah,

this is related to the first segment of the arrow that leaves the process horizontally. When you click on an arrow you can see a yellow lug point. The arrow routing on this first segment of the arrow will always be maintained horizontally (or vertically, in case the arrow is connected at the top or at the bottom of a node).

So in your Sankey diagram, all you have to do is slide the yellow lug points of all parallel arrows outward (to the right) to ensure that the first segment is absolutely horizontal (and parallel to the others).

Regards,

Peter
Peter
e!Sankey Forum Moderator
ifu Hamburg GmbH

Offline Norshah

  • Jr. Member
  • **
  • Posts: 5
Re: Arrow not straight/overlapping/gaps
« Reply #2 on: August 07, 2014, 11:14 AM »
Thank you. It does help. another things is, there is a white line between the arrows as shown below. Is there any command that can merge the arrow etc?

Thanks


Offline pbeilschmidt

  • Administrator
  • Hero Member
  • *****
  • Posts: 597
  • e!Sankey - show the flow.
    • e!Sankey - show the flow.
Re: Arrow not straight/overlapping/gaps
« Reply #3 on: August 07, 2014, 01:54 PM »
Hi Norshah,

the thin white line is where you would normally have the border of the arrow. I think the only way to get rid of it would be to turn on the border of the arrow again and set it to the same color as the fill color of the arrow.

In your case it would be simple, since they all have the same color.

Proceed as follows:
  • Select all elements of the diagram (CTRL-A)
  • In the properties panel choose "Arrows" from the "Edit Type" dropdown list at the top to edit all arrows at the same time
  • Set the checkmark for "Draw Border". All arrows now feature a black border (default color)
  • Click on the color mark to set a different border line color (in your case blue)

I remember there was a feature request that the border line color can be synchronized more easily with the fill color. However, this feature has not yet been implemented. That might be useful in your case.

Enjoy working with e!Sankey

Peter

 
Peter
e!Sankey Forum Moderator
ifu Hamburg GmbH

Offline Norshah

  • Jr. Member
  • **
  • Posts: 5
Re: Arrow not straight/overlapping/gaps
« Reply #4 on: August 07, 2014, 03:00 PM »
Hi, thanks! Yeah I have managed to delete the white gaps by changing the border line colour.